İçeriğe atla

Mikrotik Ultrasorf Engelleme

Mikrotik kullananların ortak problemi ultrasorf engelliyememesidir.

Ultrasorf engellemek için terminale aşagıdaki kodları yazmanız yeterlidir.

/ip firewall filter
add action=drop chain=forward comment="Engel UltraSurf" disabled=no dst-port=443 protocol=tcp src-address-list=UltraSurfUsers

/ip firewall mangle
add action=add-src-to-address-list address-list=UltraSurfUsers address-list-timeout=1d chain=prerouting comment="UltraSurfUsers" disabled=no dst-address-list=UltraSurfServers dst-port=443 protocol=tcp

/ip firewall address-list
add address=65.49.0.0/17 comment="" disabled=no list=UltraSurfServers
add address=204.107.140.0/24 comment="" disabled=no list=UltraSurfServers

/ip firewall filter
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.194.50 dst-port=53 protocol=tcp
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.194.50 dst-port=53 protocol=udp
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.192.50 dst-port=53 protocol=tcp
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.192.50 dst-port=53 protocol=udp
add action=drop chain=forward comment=DNS disabled=no dst-port=53 protocol=tcp
add action=drop chain=forward comment=DNS disabled=no dst-port=53 protocol=udp

Mikrotik 4 hat PPPOE kurulumu

4 hat PPPOE hattı loadbalancer yapmamız için aşagıdaki kodları terminale yazmanız yeterli.

/ip address
add address=172.16.0.1/16 broadcast=172.16.255.255 comment="" disabled=no interface=Local network=172.16.0.0
add address=192.168.1.2/24 broadcast=192.168.1.255 comment="" disabled=no interface=WAN1 network=192.168.1.0
add address=192.168.2.2/24 broadcast=192.168.2.255 comment="" disabled=no interface=WAN2 network=192.168.2.0
add address=192.168.3.2/24 broadcast=192.168.3.255 comment="" disabled=no interface=WAN3 network=192.168.3.0
add address=192.168.4.2/24 broadcast=192.168.4.255 comment="" disabled=no interface=WAN4 network=192.168.4.0
 
/ip pool
add name=dhcp_pool1 ranges=172.16.0.70-172.16.0.254
add name=pppoe-users-pool ranges=10.0.0.1-10.0.0.255
 
/ip dhcp-server add address-pool=dhcp_pool1 authoritative=after-2sec-delay bootp-support=static disabled=no interface=Local lease-time=12h name="My DHCP Server"
 
/ip dhcp-server config
set store-leases-disk=5m
 
/ip dhcp-server network
add address=172.16.0.0/16 comment="" dns-server=172.16.0.1,221.132.112.8
 
/interface pppoe-server server
add authentication=pap default-profile=default disabled=no interface=Local keepalive-timeout=10 max-mru=1480 max-mtu=1480 max-sessions=1 mrru=disabled one-session-per-host=yes service-name=virtual
 
/ppp profile add change-tcp-mss=default dns-server=172.16.0.1 local-address=172.16.0.1 name=pppoe-profile only-one=default remote-address=pppoe-users-pool use-compression=default use-encryption=default use-vj-compression=default
 
/ppp secret add caller-id=”" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=virtual password=1234 profile=pppoe-profile routes=”" service=pppoe
 
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=10000KiB max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4
 
/ip firewall mangle
add action=mark-connection chain=input comment="" disabled=no in-interface=WAN1 new-connection-mark=WAN1_conn passthrough=yes
add action=mark-connection chain=input comment="" disabled=no in-interface=WAN2 new-connection-mark=WAN2_conn passthrough=yes
add action=mark-connection chain=input comment="" disabled=no in-interface=WAN3 new-connection-mark=WAN3_conn passthrough=yes
add action=mark-connection chain=input comment="" disabled=no in-interface=WAN4 new-connection-mark=WAN4_conn passthrough=yes
 
add action=mark-routing chain=output comment="" connection-mark=WAN1_conn disabled=no new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=WAN2_conn disabled=no new-routing-mark=to_WAN2 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=WAN3_conn disabled=no new-routing-mark=to_WAN3 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=WAN4_conn disabled=no new-routing-mark=to_WAN4 passthrough=yes
 
add action=accept chain=prerouting comment="" disabled=no dst-address=192.168.1.0/24
add action=accept chain=prerouting comment="" disabled=no dst-address=192.168.2.0/24
add action=accept chain=prerouting comment="" disabled=no dst-address=192.168.3.0/24
add action=accept chain=prerouting comment="" disabled=no dst-address=192.168.4.0/24
 
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local new-connection-mark=WAN1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/0 src-address=10.0.0.1-10.0.0.255
 
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local new-connection-mark=WAN2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/1 src-address=10.0.0.1-10.0.0.255
 
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local new-connection-mark=WAN3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/2 src-address=10.0.0.1-10.0.0.255
 
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local new-connection-mark=WAN4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/3 src-address=10.0.0.1-10.0.0.255
 
add action=mark-routing chain=prerouting comment="" connection-mark=WAN1_conn disabled=no new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=WAN2_conn disabled=no new-routing-mark=to_WAN2 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=WAN3_conn disabled=no new-routing-mark=to_WAN3 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=WAN4_conn disabled=no new-routing-mark=to_WAN4 passthrough=yes
 
/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=WAN1 src-address=10.0.0.1-10.0.0.255
add action=masquerade chain=srcnat comment="" disabled=no out-interface=WAN2 src-address=10.0.0.1-10.0.0.255
add action=masquerade chain=srcnat comment="" disabled=no out-interface=WAN3 src-address=10.0.0.1-10.0.0.255
add action=masquerade chain=srcnat comment="" disabled=no out-interface=WAN4 src-address=10.0.0.1-10.0.0.255
 
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 scope=30 target-scope=10
 
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 scope=30 target-scope=10
 
add check-gateway=ping disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_WAN3 scope=30 target-scope=10
 
add check-gateway=ping disabled=no distance=4 dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=to_WAN4 scope=30 target-scope=10
 
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=30 target-scope=10
 
add check-gateway=ping comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=30 target-scope=10
 
add check-gateway=ping comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=30 target-scope=10
 
add check-gateway=ping comment="" disabled=no distance=4 dst-address=0.0.0.0/0 gateway=192.168.4.1 scope=30 target-scope=10

Mikrotik Gmail Hesabına Yedekleme

Aşagıdaki kodları terminale yazmanız yeterlidir.

Değiştirmeniz gereken yerler:

Öncelikle değiştirmeniz gereken yerler:

gmailuser GMAILUSERNAME
gmailid YOUREMAILID@gmail.com
global gmailpwd YOURCURRENTPASSWORD

global recmail RECEIVEREMAILADDRESS

/system script
add name=BackupEmail source="# Enter Sender/Receiver Details.\r\
\n\r\
\n:global gmailuser GMAILUSERNAME\r\
\n:global gmailid YOUREMAILID@gmail.com\r\
\n:global gmailpwd YOURCURRENTPASSWORD\r\
\n\r\
\n## --- Aşağıda değiştirmeyin ---- ##\r\
\n\r\
\n\r\
\n# Enter Receiver Details.\r\
\n:global recmail RECEIVEREMAILADDRESS\r\
\n\r\
\n## --- Do not change below ---- ##\r\
\n\r\
\n#:log warning \"Mikrotik Router Backup JOB Started . . . \"\r\
\n:local gmailip\r\
\n:set gmailip [:resolve \"smtp.gmail.com\"]\r\
\n:global backupfile configbackup\r\
\n:global mikrotikexport mtexport_backup\r\
\n:global sub1 ([/system identity get name])\r\
\n:global sub2 ([/system clock get time])\r\
\n:global sub3 ([/system clock get date])\r\
\n:log warning \"Creating new up to date backup files . . . \"\r\
\n\r\
\n/system backup save dont-encrypt=yes name=\$backupfile\r\
\n/export compact file=\$mikrotikexport\r\
\n\r\
\n/tool e-mail set address=\$gmailip from=\$gmailid password=\$gmailpwd port=587 start-tls=yes user=\$gmailuser\r\
\n\r\
\n:log warning \"Backup process pausing for 10s so it can complete creating backup if system is busy ...\"\r\
\n:delay 10s\r\
\n:log info \"Start Sending Backup File via Email using GMAIL SMTP . . .\"\r\
\n/tool e-mail send to=\$recmail password=\$gmailpwd subject=\"\$sub3 \$sub2 \$sub1 Configuration BACKUP File\" from=\$gmailid file=\$backupfile server=\$gmailip start-tls=yes\r\
\n:delay 30s\r\
\n/tool e-mail send to=\$gmailid password=\$gmailpwd subject=\"\$sub3 \$sub2 \$sub1 Configuration EXPORT File\" from=\$gmailid file=\$mikrotikexport server=\$gmailip start-tls=yes\r\
\n# Delete Old backup files to save space.\r\
\n/file remove \$backupfile\r\
\n:delay 30s\r\
\n/file remove \$mikrotikexport\r\
\n/tool e-mail set address=0.0.0.0 from=<> password=xxxx port=25 start-tls=yes user=yourid\r\
\n:log warning \"Backup Finished & Backup File Removed. All Done. You should verify your inbox for confirmation\""

Aşagıdaki kodu zamanlanmış görevlere ekleyiniz


/system scheduler
add interval=1d name=BackupByEmail on-event=BackupEmail start-date=apr/03/2016 start-time=00:15:00

 

Torrent Engelleme

192.168.0.0/24 blogundaki torrent ve p2p trafigi engellemek için aşagıdaki kodları kullanabilirsiniz.

/ip firewall layer7-protocol
add name=torrentsites regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|torrentz|vertor|h33t|btscene|bitunity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova|bitsoup|meganova|fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|commonbits).*\$"

/ip firewall filter
add chain=forward src-address=192.168.0.0/24 layer7-protocol=torrentsites action=drop comment=torrentsites
add chain=forward src-address=192.168.0.0/24 protocol=17 dst-port=53 layer7-protocol=torrentsites action=drop comment=dropDNS
add chain=forward src-address=192.168.0.0/24 content=torrent action=drop comment=keyword_drop
add chain=forward src-address=192.168.0.0/24 content=tracker action=drop comment=trackers_drop
add chain=forward src-address=192.168.0.0/24 content=getpeers action=drop comment=get_peers_drop
add chain=forward src-address=192.168.0.0/24 content=info_hash action=drop comment=info_hash_drop
add chain=forward src-address=192.168.0.0/24 content=announce_peers action=drop comment=announce_peers_drop

# Ayrıca aşagıdaki koduda eklemeniz iyi olur

add chain=forward src-address=192.168.0.0/24 p2p=all-p2p action=drop comment=p2p_drop

Whatsapp Messenger Engelleme

İçerik mikrotik için geçerlidir. Konsola aşagıdaki kodları yazmanız ile beraber whatappmessenger çalışmaz.


/ip firewall address-list
add address=31.13.64.51 list=Whatsapp
add address=31.13.65.49 list=Whatsapp
add address=31.13.66.49 list=Whatsapp
add address=31.13.67.51 list=Whatsapp
add address=31.13.69.240 list=Whatsapp
add address=31.13.70.49 list=Whatsapp
add address=31.13.71.49 list=Whatsapp
add address=31.13.72.52 list=Whatsapp
add address=31.13.73.49 list=Whatsapp
add address=31.13.74.49 list=Whatsapp
add address=31.13.75.52 list=Whatsapp
add address=31.13.76.81 list=Whatsapp
add address=31.13.77.49 list=Whatsapp
add address=31.13.79.195 list=Whatsapp
add address=31.13.80.53 list=Whatsapp
add address=31.13.81.53 list=Whatsapp
add address=31.13.82.51 list=Whatsapp
add address=31.13.83.51 list=Whatsapp
add address=31.13.84.51 list=Whatsapp
add address=31.13.85.51 list=Whatsapp
add address=31.13.86.51 list=Whatsapp
add address=31.13.87.51 list=Whatsapp
add address=31.13.88.49 list=Whatsapp
add address=31.13.88.57 list=Whatsapp
add address=31.13.90.51 list=Whatsapp
add address=31.13.91.51 list=Whatsapp
add address=31.13.92.52 list=Whatsapp
add address=31.13.93.51 list=Whatsapp
add address=31.13.95.63 list=Whatsapp
add address=50.22.75.192/27 list=Whatsapp
add address=50.22.93.192/27 list=Whatsapp
add address=50.22.198.204/30 list=Whatsapp
add address=50.22.210.32/30 list=Whatsapp
add address=50.22.210.128/27 list=Whatsapp
add address=50.22.225.64/27 list=Whatsapp
add address=50.22.235.248/30 list=Whatsapp
add address=50.22.240.160/27 list=Whatsapp
add address=50.23.90.128/27 list=Whatsapp
add address=50.97.57.128/27 list=Whatsapp
add address=75.126.39.32/27 list=Whatsapp
add address=108.168.174.0/27 list=Whatsapp
add address=108.168.176.192/26 list=Whatsapp
add address=108.168.177.0/27 list=Whatsapp
add address=108.168.180.96/27 list=Whatsapp
add address=108.168.254.65 list=Whatsapp
add address=108.168.255.224 list=Whatsapp
add address=108.168.255.227 list=Whatsapp
add address=158.85.0.96/27 list=Whatsapp
add address=158.85.5.192/27 list=Whatsapp
add address=158.85.46.128/27 list=Whatsapp
add address=158.85.48.224/27 list=Whatsapp
add address=158.85.58.0/25 list=Whatsapp
add address=158.85.61.192/27 list=Whatsapp
add address=158.85.224.160/27 list=Whatsapp
add address=158.85.233.32/27 list=Whatsapp
add address=158.85.249.128/27 list=Whatsapp
add address=158.85.249.224/27 list=Whatsapp
add address=158.85.254.64/27 list=Whatsapp
add address=169.53.29.128/27 list=Whatsapp
add address=169.53.71.224/27 list=Whatsapp
add address=169.53.250.128/26 list=Whatsapp
add address=169.54.2.160/27 list=Whatsapp
add address=169.54.51.32/27 list=Whatsapp
add address=169.54.55.192/27 list=Whatsapp
add address=169.54.210.0/27 list=Whatsapp
add address=169.54.222.128/27 list=Whatsapp
add address=169.55.69.128/26 list=Whatsapp
add address=169.55.74.32/27 list=Whatsapp
add address=169.55.235.160/27 list=Whatsapp
add address=173.192.162.32/27 list=Whatsapp
add address=173.192.219.128/27 list=Whatsapp
add address=173.192.222.160/27 list=Whatsapp
add address=173.192.231.32/27 list=Whatsapp
add address=173.193.205.0/27 list=Whatsapp
add address=173.193.230.96/27 list=Whatsapp
add address=173.193.230.128/27 list=Whatsapp
add address=173.193.230.192/27 list=Whatsapp
add address=173.193.239.0/27 list=Whatsapp
add address=174.36.208.128/27 list=Whatsapp
add address=174.36.210.32/27 list=Whatsapp
add address=174.36.251.192/27 list=Whatsapp
add address=174.37.199.192/27 list=Whatsapp
add address=174.37.215.28/30 list=Whatsapp
add address=174.37.217.64/27 list=Whatsapp
add address=174.37.231.64/27 list=Whatsapp
add address=174.37.243.64/27 list=Whatsapp
add address=174.37.251.0/27 list=Whatsapp
add address=179.60.192.51 list=Whatsapp
add address=179.60.193.51 list=Whatsapp
add address=179.60.195.51 list=Whatsapp
add address=184.173.73.176/28 list=Whatsapp
add address=184.173.136.64/27 list=Whatsapp
add address=184.173.147.32/27 list=Whatsapp
add address=184.173.161.64 list=Whatsapp
add address=184.173.161.160/27 list=Whatsapp
add address=184.173.173.116 list=Whatsapp
add address=184.173.179.32/27 list=Whatsapp
add address=184.173.195.32/27 list=Whatsapp
add address=184.173.201.32/27 list=Whatsapp
add address=184.173.204.32/27 list=Whatsapp
add address=184.173.250.53 list=Whatsapp
add address=192.155.212.192/27 list=Whatsapp
add address=198.11.193.182/31 list=Whatsapp
add address=198.11.212.0/27 list=Whatsapp
add address=198.11.217.192/27 list=Whatsapp
add address=198.11.251.32/27 list=Whatsapp
add address=198.23.80.0/27 list=Whatsapp
add address=198.23.86.224/27 list=Whatsapp
add address=198.23.87.64/27 list=Whatsapp
add address=208.43.115.192/27 list=Whatsapp
add address=208.43.117.79 list=Whatsapp
add address=208.43.117.136 list=Whatsapp
add address=208.43.122.128/27 list=Whatsapp

/ip firewall filter
add chain=forward dst-address-list=Whatsapp action=drop comment="Whatsapp Engel"
add chain=input src-address-list=Whatsapp action=drop comment="Whatsapp Engel"

PHP Yazılımcısı Arıyoruz

Merhaba Arkadaşlar,

Aranan Nitelikler:

PHP konusunda nesne yönelimli (object oriented) kodlama yetisine hakim,
XHTML, CSS, JavaScript, Php ve MySQL konularında deneyimli,
PHP Framework üzerinde çalışmış, tercihen Laravel frameworkine hakim,
Tercihen ilgili Bölümlerden Mezun,
Tercihen en az 2 yıl tecrübeli,
Web Servis, SOAP, REST API ile bilgisi olan,
Javascript konusunda popüler kütüphanelerle(özellikle jQuery) kod geliştirmiş ve AJAX teknolojisine hakim,
Özgün çalışmalarını referans olarak sunabilecek,
Yaratıcı fikirler üretebilen,
Öğrenmeyi ve araştırmayı seven,
Yoğun iş temposuna ve ekip çalışmasına ayak uydurabilecek,
Web teknolojileri konusunda bilgi sahibi, yenilikleri takip edebilen ve uygulayabilen,
İŞ TANIMI
Şirket içi ve şirket dışı web ihtiyaçlarının karşılanması,
Şirket içi ve şirket dışı web ihtiyaçlarının gerektiğinde analizine yönlendirici olunması,
Yeni ürünlerin yazılım tasarımlarının gerçekleştirilmesi,
Şirkete özgü yazılım araçlarının geliştirilmesi,
Ürün revizyonlarının yapılması.
Bilişim sektöründe faaliyet gösteren firmamızın Denizli ofisinde görevlendirilmek üzere PHP Yazılım Uzmanı arıyoruz.
info@hms.gen.tr CV lerini mail olarak göndermelerini rica ediyoruz.

Ne Üzerine Yazılım Yapmalıyım?

Uzun süredir yazılım sektöründe ugraşan biri olarak öncelikle yazılım yapacagınız sektörde mesai saatleri kavramları olması gerekiyor. Örnegin ben otel programı üzerine bir yazılım yaptım. Ne mesai saati kavramı var nede bayram günleri. Eğer ilerleyen süreçte aile hayatı yaşamak istiyorsanız bu tür problemler sizin için çok önemli olabilir. En basitinden KBS (Kimlik Bildirim Sistemi) Gece bildirim yapılmaktadır. Problem yaşandıgında sizi ararlar. Gece 1:30 da olabilir bu zaman.  Düşünün bir misafirlige gidiyorsunuz gece 12 de telefonlarınız çalıyor ve problemler iletiliyor. İlk başlangıçta tamam normal diyorsanız ama sonra bir yerden sonra sıkıyor. Ayrıca sektörde uluslararası rekabet eden programlarda cabası.

Size tavsiyem bir yazılım yapacaksanız öncelikle mesai saatleri kavramı olacak ve uluslar arası rekabet edecek firmalar olmamalı eger bunlar olmyan sektör secerseniz hem kazancınız yüksek olur hemde kafanız…